Page tree
Skip to end of metadata
Go to start of metadata

See the Avalon 6.4 Release Notes for more information.


Requirements

Avalon 6.3 and above requires Ruby 2.3 or newer. If you're using RVM, simply run

rvm list # Get current ruby version, eg 2.2.1
rvm upgrade 2.2.1 2.4.1 # Installs Ruby 2.4.1 and migrate gemsets, wrappers, aliases and environment files

Upgrade Steps

For Manual Installations

Download and deploy new code from the avalon repository.

Update gems and DB

bundle install
RAILS_ENV=production bundle exec rake db:migrate

Restart passenger (if using)

passenger-config restart-app

Restart Resque (background jobs processor)

pkill -f resque
RAILS_ENV=production BACKGROUND=yes bundle exec rake resque:scheduler
RAILS_ENV=production BACKGROUND=yes QUEUE=* bundle exec rake resque:work

For Docker Installations

Update new code from avalon-docker

git checkout master
git pull

Note that the names of some environment variables have changed (in docker-compose.yml):

-      - REDIS_SERVER=redis:6379
+      - SETTINGS__REDIS__HOST=redis
+      - SETTINGS__REDIS__PORT=6379

Rebuild and replace Avalon container. 

docker-compose build --no-cache avalon
docker-compose stop avalon
docker-compose up avalon



  • No labels