Page tree
Skip to end of metadata
Go to start of metadata

Requirements

Ruby 2.7.x is recommended.

Config changes

Old settingNew settingNote


redis:
  db: 0


dropbox:
  google_drive:
    client_id: 'google-id'
    client_secret: 'secret-from-google'


active_storage:
  bucket: 'supplementalfiles'
  root: 'storage'

  • The redis database is now configurable.  This setting will default to 0 which is the default redis database.
  • Google Drive is now an option for the dropbox modal.  See Google Drive Dropbox for more details.

  • The directory used for storing supplemental files locally can now be configured using the root setting and in s3 or minio using the bucket setting.  This avoids the need to edit config/storage.yml

Upgrade Steps

For Manual Installations

  1. Install ruby 2.7
  2. Update gems, and migrate DB
bundle install --with production --without development test
RAILS_ENV=production bundle exec rake db:migrate

3. Update JS dependencies

yarn install # in Avalon root dir

4. Update configuration, see Config changes above

5. Restart passenger (if using)

passenger-config restart-app

For Docker Installations

Update new code from avalon-docker

git checkout master
git pull

Pull new Avalon image. 

docker-compose pull avalon

Check config changes then replace the Avalon containers

docker-compose up avalon worker

You can also build your own image, Docker Buildkit is recommended

docker-compose build avalon
  • No labels