Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Code Block
yum install ffmpeg

 

If installing ffmpeg with yum doesn't work, or you have dependency problems, you can try installing it from source.

Code Block
git clone git://source.ffmpeg.org/ffmpeg.git ffmpeg
cd ffmpeg
./configure --enable-gpl --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb \
  --enable-libopencore-amrwb --enable-librtmp --enable-libtheora --enable-libvorbis \
  --enable-libvpx --enable-libx264 --enable-nonfree --enable-version3 --enable-x11grab
make

That configure statement might need to change. It worked for me, but it seems puppet has more options enabled.

Go to felix/etc/config.properties and make sure you're pointing to the correct ffmpeg.

Then go to MediaInfo's website to install MediaInfo.

...